Maryland license monitoring Issue

Incident Report for MVR Service

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 07:50 PDT

Investigating

We have identified a potential issue with Maryland enrollment and annual MVRs. We are investigating to understand impact and steps to resolve.
Posted Jun 04, 2025 - 14:45 PDT